Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 função SOMASE">"

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
marcelodurco



Mensagens : 4
Data de inscrição : 08/04/2015

MensagemAssunto: função SOMASE">"   Qua Abr 08, 2015 7:31 pm

Prezados boa tarde;

Vejam se conseguem me auxiliar.

Preciso inserir uma formula que compare os dados inseridos na coluna A:A com o valor informado na célula N1, depois N2, e assim sucessivamente; caso o valor informado na coluna A:A seja superior ao da célula N1 (por exemplo) preciso somar os valores dispostos na coluna C:C.

Para ficar mais claro:

Coluna A (Data), Coluna C (Km) e Coluna N (data do trabalho); suponhamos que tenhamos a seguinte estrutura:
A1 = 01/02/2015 ; c1 = 10 e N1 = 01/01/2015
A2 = 01/12/2014 ; c2 = 20 e N1= 01/01/2015
A3 = 15/012015 ; C3 = 30 e N1 = 01/01/2015

Desta forma preciso que o Excel some para mim os valores das células C1 e C3, excluindo a célula C2 pois nesta a Data (A2) informada é inferior a data do trabalho (N1).

Tentei com a função SOMASE, porém está não permiti utilizar o critério ">N1", pois o Excel entende que N1 é um texto e não uma célula.

Existe alguma fórmula para tal função?
Se não como escrevo uma MACRO que indique isso?

Att.:
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: função SOMASE">"   Qua Abr 08, 2015 10:24 pm

Boa tarde!!

deveria ter colocado o resultado .....
seria isso?
Código:
=SOMARPRODUTO(($A$2:$A$400>N2)*($C$2:$C$400))
Faça os testes


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marcelodurco



Mensagens : 4
Data de inscrição : 08/04/2015

MensagemAssunto: Re: função SOMASE">"   Qui Abr 09, 2015 3:54 am

alexandrevba escreveu:
Boa tarde!!

deveria ter colocado o resultado .....
seria isso?
Código:
=SOMARPRODUTO(($A$2:$A$400>N2)*($C$2:$C$400))
Faça os testes


Att

Alexandre boa noite,

Era exatamente isso, muito obrigado pelo apoio, na realidade eu precisava comparando duas variáveis e somando uma terceira, já adaptei e o resultado está correto.

Utilizei assim.

=somarproduto((A:A>N2)*(B:B=F2)*(C:C))

Desta maneira comparo o valor data e seleciono somente aquelas que são maiores que a data informada na célula N2, comparo os valores informados no campo código (coluna B) e seleciono somente aqueles que tem o código idêntico ao informado na célula, por fim somo os valores correspondentes as linhas destas combinações inseridos na coluna C.

Muito obrigado pelo apoio, foi fundamental na resolução do problema.

Grato!

Att.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: função SOMASE">"   Qui Abr 09, 2015 2:02 pm

Bom dia!!

Eu fico feliz que resolveu, obrigado pelo retorno!!


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: função SOMASE">"   Hoje à(s) 8:55 am

Voltar ao Topo Ir em baixo
 
função SOMASE">"
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Expressões matemáticas, funções e operadores
» [Resolvido]como usar a função jump to start por codigo?
» [RESOLVIDO]2 funções utilizando a mesma tecla???
» [Vídeo-Aula]Aula 4.1 - Usando funções básicas do draw
» Background - Funções e Variáveis

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: