Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Formula se aninhada com resultado entre valores

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Marcos Paiva



Mensagens : 2
Data de inscrição : 13/04/2015

MensagemAssunto: Formula se aninhada com resultado entre valores   Seg Abr 13, 2015 12:50 am

=SE(G3>89;"O";SE(G3=70<90;"B";SE(G3=50<70;"S";"I")))

na coluna determinada deverá aparecer somente O, B, S ou I.

porém existe uma inconsistência e não consegui encontrar.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Formula se aninhada com resultado entre valores   Seg Abr 13, 2015 2:42 pm

Bom dia!!

Além da sintaxe errada, não está sendo possível entender seu critério

Use o PROCV!!

Código:
=PROCV(G3;K1:L4;2;VERDADEIRO)

Nas colunas K e L
Citação :

Criterio-----Resultado
50--------------S
70--------------B
90--------------O
Agora, é só ajustar a sua condição, caso a minha não o satisfaça.

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Marcos Paiva



Mensagens : 2
Data de inscrição : 13/04/2015

MensagemAssunto: Boa noite não expliquei legal o que preciso, tenho um valor de média na coluna G. na coluna H essa média tem que se transformar em letras de 0 a 49 = I, de 50 a 69 = S, de 70 a 89 = B e de 90 a 100 = O. Isso que não estou conseguindo fazer.   Ter Abr 14, 2015 12:47 am

alexandrevba escreveu:
Bom dia!!

Além da sintaxe errada, não está sendo possível entender seu critério

Use o PROCV!!

Código:
=PROCV(G3;K1:L4;2;VERDADEIRO)

Nas colunas K e L
Citação :

Criterio-----Resultado
50--------------S
70--------------B
90--------------O
Agora, é só ajustar a sua condição, caso a minha não o satisfaça.

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Formula se aninhada com resultado entre valores   Ter Abr 14, 2015 2:04 pm

Bom dia!!

Vá em :
http://gurudoexcel.com/forum/index.php

Após o cadastro poste seu arquivo modelo!

Ou considere uma correção para
Código:
=PROCV(H2;$A$1:$B$5;2)

Considerando que
Na coluna A e B há os dados (tabela) para comprar com a coluna H
Citação :

NumMedia-Resultado
0-I
50-S
70-B
90-O

Sabendo que em H2...h3. etc tem a média (valores).
Então em I2 coloque a formula acima.

Obs: É sabido usar o PROCV, quando tem que comparar usando muitos SE's aninhado!!!!!!!!!!!!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Formula se aninhada com resultado entre valores   Hoje à(s) 8:54 am

Voltar ao Topo Ir em baixo
 
Formula se aninhada com resultado entre valores
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Formula para interpolação de valores
» qual é a diferença entre get e set?
» Ql a diferença entre variaves e variaveis globais ?
» Pegar o texto entre tags!
» Colisão entre objetos

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: