Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Somar A1:A10 com valores se a B1:B10 tiverem Data.

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
SPP



Mensagens : 37
Data de inscrição : 05/06/2013
Idade : 63
Localização : Muriaé MG

MensagemAssunto: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Sex Out 30, 2015 10:16 pm

Boa Tarde!
Gostaria de saber qual formula Usar para somar A1:A10 com valores se a B1:B10 tiverem Data,mas só as que contiverem datas respectiva.

EdivanCabra

Não Entendeu
Eu tenho que soma qualquer data que estiver na celulas independente da data que estive e os campos vazios. Não posso determinar que data as pessoas vão colocar


Última edição por SPP em Qua Nov 04, 2015 12:16 am, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
EdivanCabral



Mensagens : 4
Data de inscrição : 03/11/2015

MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Ter Nov 03, 2015 5:55 pm

SPP escreveu:
Boa Tarde!
Gostaria de saber qual formula Usar para somar A1:A10 com valores se a B1:B10 tiverem Data,mas só as que contiverem datas respectiva.

Tente assim:

=SOMASES(A1:A10;B1:B10;">="&"01/01/2015";B1:B10;"<="&"31/01/2015")

Troque as datas que estao em laranja pelas células onde esta as suas ou pelas data que desejar....


Visite meu blog:
programacaopassoapasso.wordpress.com
Voltar ao Topo Ir em baixo
Ver perfil do usuário
SPP



Mensagens : 37
Data de inscrição : 05/06/2013
Idade : 63
Localização : Muriaé MG

MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Qua Nov 04, 2015 12:18 am

EdivanCabra

Não Entendeu
Eu tenho que soma qualquer data que estiver na celulas independente da data que estive e os campos vazios. Não posso determinar que data as pessoas vão colocar
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Sex Nov 06, 2015 6:04 pm

Boa tarde!!

Tente isso:
Código:
=SOMASE(B1:B10;"<>";A1:A10)

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
SPP



Mensagens : 37
Data de inscrição : 05/06/2013
Idade : 63
Localização : Muriaé MG

MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Sab Nov 07, 2015 2:53 am

Alexandre Boa Noite!

E isto mesmo que estava precisando, mas já tinha conseguido desta forma ontem. Mesmo Asim valeu a sua forma tambem funcionou. obrigado pelo Interece.

=SOMARPRODUTO((B1:B10<>"")*(A1:A10)) Soma os valores com data.
=SOMARPRODUTO((B1:B10="")*(A1:A10)) Soma os valores sem data.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Sab Nov 07, 2015 4:07 am

Boa noite!!

Eu fico feliz que resolveu, precisando... Laughing


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Somar A1:A10 com valores se a B1:B10 tiverem Data.   Hoje à(s) 8:22 pm

Voltar ao Topo Ir em baixo
 
Somar A1:A10 com valores se a B1:B10 tiverem Data.
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Guardar valores de variaveis locais - -'
» È possível unir tópicos e mensagens á seus valores?
» Formula para interpolação de valores
» somar links com rb750
» Agrupar e somar valores em consultas com datas

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: