Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Busca de valores que se repetem

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
the_real_one



Mensagens : 2
Data de inscrição : 08/12/2011

MensagemAssunto: Busca de valores que se repetem   Qui Dez 08, 2011 9:15 pm

E aí galera, blz?

Tenho alguns conhecimentos em Excel, e no entanto estou com dificuldades em fazer o seguinte:

Tenho duas planilhas.

Uma delas eu cadastro notas fiscais e seus valores. Exemplo:




Na outra planilha, eu faço um resumo de saldos de cada nota fiscal que ainda existem a pagar, buscando com PROCV.

Exemplo (com a fórmula)




Exemplo (sem a fórmula)




O que acontece é que, a cada pagamento, a nota deve ser lançada novamente. Então a planilha fica assim:




E a planilha dos resumos fica assim:




O problema é que o PROCV pega somente o primeiro valor que ele encontra. Ou seja, o saldo da nota, na outra planilha, usando o PROCV, será sempre 30,00, que é o primeiro saldo que a fórmula encontra.

Alguém poderia me ajudar com isso? A primeira planilha não tem como ser alterada. E a segunda planilha deve exibir o saldo atual.

Muito Obrigado!


Ulisses









Voltar ao Topo Ir em baixo
Ver perfil do usuário
the_real_one



Mensagens : 2
Data de inscrição : 08/12/2011

MensagemAssunto: Re: Busca de valores que se repetem   Qui Dez 08, 2011 9:16 pm

P.S.: A fórmula do PROCV busca a 3ª coluna, e não a 2ª, como está printado.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Busca de valores que se repetem   Sex Dez 09, 2011 3:27 am

Boa noite!!!


Isso é fácil ..mas deveria ter postado sua planilha ...

Exemplo de funções aninhadas...

Citação :
SE(ÉERROS(CORRESP(LIN(E5);base!$R$2:$R$500;0));"";ÍNDICE(base!E$2:E$500;CORRESP(LIN(A5);base!$R$2:$R$500;0)))

Caso não consiga resolver poste sua planilha em site gratuito com www.4shared.com
Att...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Marreco12



Mensagens : 28
Data de inscrição : 12/10/2011

MensagemAssunto: Re: Busca de valores que se repetem   Sab Dez 10, 2011 1:35 am

Ulisses seja bem vindo ao forum.
Usa a formula abaixo na célula B3 da Plan2
=SE(A3<>"";ÍNDICE(Plan1!$C$3:$C$10;MÁXIMO(LIN(Plan1!$C$3:$C$10)*(Plan1!$A$3:$A$10=A3))-2);"")
e ai Preciona SHIFT+CTRL+ENTER

e ela deve fica com se seguinte aparencia
{=SE(A3<>"";ÍNDICE(Plan1!$C$3:$C$10;MÁXIMO(LIN(Plan1!$C$3:$C$10)*(Plan1!$A$3:$A$10=A3))-2);"")}
Entre chaves.
Ai é só copiar para as demais células

o limite da formula esta um pouco maior do que você mostrou na figura, mas ai é só estabelece o limite até onde você estima que vá a digitação das notas fiscais

Veja se isso resolve.
Abraço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Busca de valores que se repetem   Hoje à(s) 1:32 pm

Voltar ao Topo Ir em baixo
 
Busca de valores que se repetem
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Guardar valores de variaveis locais - -'
» Retirar caixa de busca
» Desativar busca do fórum
» Imagem de fundo na caixa de busca
» Remover campo de busca

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: