Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 PROCV COM INTERVALO DE DATAS + FREQUÊNCIA ou index match

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
WILLIAN.TOMAZI



Mensagens : 1
Data de inscrição : 31/12/2015

MensagemAssunto: PROCV COM INTERVALO DE DATAS + FREQUÊNCIA ou index match   Qui Dez 31, 2015 8:17 pm

Tenho uma planilha com duas colunas, sendo a primeira com datas preenchidas aleatoriamente e a segunda com números, podendo conter células vazias:

01/07/2015 5
01/07/2015 2
02/07/2015 5
03/07/2015
05/08/2015 3
05/08/2015 5
03/07/2015 8
06/08/2015 2
20/08/2015 7

fazer a soma é fácil, mas o que eu quero é calcular a frequência dos números dentro de cada mês, ignorando células vazias e células que não são do mês específico.

No exemplo acima, a frequência de 5 para o mês 7 seria 2 (pois aparece 2 vezes neste mês)

Não quero fazer isto com SOMARPRODUTO pois já tentei e não deu certo! Só funciona para a tabela inteira, só para o mês que desejo, não dá certo e nã0 calcula corretamente.

Minha dúvida é:

Como eu calculo a frequência com que os números aparecem a CADA MÊS? Quero aplicar a função frequência somente no 'range' do mês específico.


Acredito que uma solução possível seria gerar uma matriz de valores da segunda coluna, selecionando somente os que correspondem ao mês procurado, mas é exatamente isto que não estou conseguindo fazer, não que usar VBA, desejo uma solução usando apenas as funções nativas do excel.




Voltar ao Topo Ir em baixo
Ver perfil do usuário
Patropi



Mensagens : 49
Data de inscrição : 14/06/2012
Localização : Campo Mourão - PR

MensagemAssunto: Re: PROCV COM INTERVALO DE DATAS + FREQUÊNCIA ou index match   Dom Jan 10, 2016 10:30 pm

Boa tarde Willian

Seja bem-vindo ao fórum!

A função certa pra este caso é a função SOMARPRODUTO.
A função não funcionou para você, porque vc deve ter montado a formula de forma errada.

Utilize a fórmula --> =SOMARPRODUTO((MÊS(A1:A9)=7)*(B1:B9=5))

Para comprovar o perfeito funcionamento, segue planilha.
Para baixar copie o link abaixo e cole no teu navegador, retirando os asteriscos que fui obrigado a colocar, pois o fórum não aceita link.

w*w*w*sendspace.com/file/rbnu5u

Quando a página do sendspace abrir -->para baixar a planilha ---> clique no retângulo azul com a inscrição Download.

Dê retorno.

[]s
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
PROCV COM INTERVALO DE DATAS + FREQUÊNCIA ou index match
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» intervalo entre datas
» [resolvido] Intervalo entre disparos
» index ?
» Alguem pode me ajudar a colocar uma logo na index ?
» Problemas nas datas

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: