Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 soma de celulas alfanumericas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
bicas



Mensagens : 3
Data de inscrição : 10/12/2011

MensagemAssunto: soma de celulas alfanumericas   Sab Dez 10, 2011 10:37 pm

Bom dia tenho o dumento abaixo que tem dados alfanumericos que preciso de somar, gostaria que me ajudassem de forma a somar os dados e subtrair os valores q estao marcado como debito.

de verificar que existem pelo meio celulas em branco.

Alguem me pode ajudar ou com uma formula para este problema ou macro. sendo que preferencialmente formula.

docs.google.com/spreadsheet/ccc?key=0AnLGLqrITr4GdDNOX2NwVU52VmJUcHFuY2RWSmtRaGc
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: soma de celulas alfanumericas   Dom Dez 11, 2011 12:55 am

Boa noite!!!

Use uma coluna adjacente com a função ....

Código:
=SE(B2="";"";ESQUERDA(B2;PROCURAR("EUR";B2)-1))

Depois complemente com a Somase...

Att..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bicas



Mensagens : 3
Data de inscrição : 10/12/2011

MensagemAssunto: Re: soma de celulas alfanumericas   Dom Dez 11, 2011 5:34 pm

alexandrevba escreveu:
Boa noite!!!

Use uma coluna adjacente com a função ....

Código:
=SE(B2="";"";ESQUERDA(B2;PROCURAR("EUR";B2)-1))

Depois complemente com a Somase...

Att..

Obrigado.

Ja usei, no entanto quando faco a soma.se da.me um erro, podem verificar aqui

http://docs.google.com/spreadsheet/ccc?key=0AnLGLqrITr4GdG8zVThlRnhzYnl0YmRma2FfNnNmcVE

obrigado pela ajuda...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Marreco12



Mensagens : 28
Data de inscrição : 12/10/2011

MensagemAssunto: Re: soma de celulas alfanumericas   Dom Dez 11, 2011 10:33 pm

Só não funcionou porque falto converte o valor para numero, pois ainda esta como texto.

E aplicando a a função valor na formula apresentada pelo Alexandre:
=SE(B2="";"";Valor(ESQUERDA(B2;PROCURAR("EUR";B2)-1)))


Outra formula só apresentando outras funções.
=SE(B2="";"";VALOR(ESQUERDA(B2;NÚM.CARACT(B2)-4)))

E a sunção soma ficaria assim:
=SOMASE(C2:C31;G2;D2:D31)
Onde G2 estaria escrito Debit

Abraço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
bicas



Mensagens : 3
Data de inscrição : 10/12/2011

MensagemAssunto: Re: soma de celulas alfanumericas   Dom Dez 11, 2011 11:20 pm

Marreco12 escreveu:
Só não funcionou porque falto converte o valor para numero, pois ainda esta como texto.

E aplicando a a função valor na formula apresentada pelo Alexandre:
=SE(B2="";"";Valor(ESQUERDA(B2;PROCURAR("EUR";B2)-1)))


Outra formula só apresentando outras funções.
=SE(B2="";"";VALOR(ESQUERDA(B2;NÚM.CARACT(B2)-4)))

E a sunção soma ficaria assim:
=SOMASE(C2:C31;G2;D2:D31)
Onde G2 estaria escrito Debit

Abraço


OBRIGADO...
Problem solved.

Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: soma de celulas alfanumericas   Hoje à(s) 9:57 am

Voltar ao Topo Ir em baixo
 
soma de celulas alfanumericas
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Como por efeito hover nas celulas "Fórum, Tópicos, Mensagens e Últimas mensagens"? no Pun PHP?
» Ocultar Cor do quadro das celulas
» Células
» Como mesclar células do fórum (tal como no phpBB3)
» Imagens Dinâmica

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: