Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Contar palavras repetidas dando como base uma célula

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Jordy



Mensagens : 2
Data de inscrição : 12/01/2012

MensagemAssunto: Contar palavras repetidas dando como base uma célula   Qui Jan 12, 2012 9:24 am

Olá,
Minha primeira vez aqui então espero estar postando na categoria correta.
Enfim, tenho a seguinte situação:
- Por meio de um formulário pessoas inserem um nome de usuário;
- O nome inserido é adicionado a uma planilha.

O que quero é basicamente fazer com que em outra coluna apareça se o nome inserido já foi inserido anteriormente ou não. Estou tentando utilizar a fórmula SE para que caso o nome nunca tenha sido inserido apareça algo como OK e casa já tenha sido inserido apareça REPETIDO.
O problema é que esta fórmula apenas conta números, não faz a comparação de palavras. Até faz, mas eu teria que dar a palavra para que ela possa comparar, e é impossível eu dar todos os nomes que as pessoas podem escrever, posso apenas dar uma célula como referência.
É possível solucionar isto por meio de uma fórmula?

Obrigado pela atenção.
Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Contar palavras repetidas dando como base uma célula   Sex Jan 13, 2012 1:50 am

Boa noite!!

Imagine que na coluna "A" você tenha vários nomes e quando um deles se repetir uma formula na coluna "B" vai te dizer se é um nome repetido.


=SE(CONT.SE(A:A;A2)>1;"Repetido";"Ok")

Espero ter entendido e ajudado.

Att..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Jordy



Mensagens : 2
Data de inscrição : 12/01/2012

MensagemAssunto: Re: Contar palavras repetidas dando como base uma célula   Sex Jan 13, 2012 5:31 am

alexandrevba escreveu:
Boa noite!!

Imagine que na coluna "A" você tenha vários nomes e quando um deles se repetir uma formula na coluna "B" vai te dizer se é um nome repetido.


=SE(CONT.SE(A:A;A2)>1;"Repetido";"Ok")

Espero ter entendido e ajudado.

Att..

Não só entendeu como ajudou e muito! Obrigado Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Contar palavras repetidas dando como base uma célula   Sab Jan 14, 2012 1:21 am

Boa noite!!

Que bom que resolveu..fico feliz..abraços ate próxima.
cheers

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Contar palavras repetidas dando como base uma célula   Hoje à(s) 8:57 pm

Voltar ao Topo Ir em baixo
 
Contar palavras repetidas dando como base uma célula
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido]Identificar último dia útil de cada mês usando como base o ano
» Como criar base de dados?
» Como colocar meta de palavras-chave no fórum?
» Como aceder ao css base
» Como limpar o dossier de base

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: