Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 [RESOLVIDO] combinação de funções procv e SE

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
eduardoniluiz



Mensagens : 6
Data de inscrição : 17/02/2012

MensagemAssunto: [RESOLVIDO] combinação de funções procv e SE   Sex Fev 17, 2012 8:35 pm

estou com um problema e preciso de ajuda pessoal.
tenho em uma planilha celulas "a1"= projeto1, "a2"=10, "b1"=projeto2, "b2"=10, "c1"=projeto3, "c2"=10
na coluna "d" vou realizar lançamentos de números e na coluna "e" lançamento dos projetos, exemplo
d2=3, e2= projeto1
gostaria de uma formula que verifica-se no intervalo da coluna "e" quais campos são projeto1, pegasse o valor correspondente na coluna "d" que no caso seria 3 e subtrai-se da célula a2. o resultado seria 7.
no caso seriam lançamentos múltiplos, então no intervalo da coluna "e" pode ter 4 lançamentos projeto1

tentei este raciocínio, mas me disseram que deveria usar o procv junto.
=SE((E2:E10 ="projeto1"); A2 - SOMA(D2:D10))

Grato


Última edição por eduardoniluiz em Seg Fev 27, 2012 5:36 pm, editado 1 vez(es) (Razão : solução encontrada)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Sab Fev 18, 2012 1:32 am

Boa noite!!!

Seria melhor postar seu arquivo!!

Voltar ao Topo Ir em baixo
Ver perfil do usuário
eduardoniluiz



Mensagens : 6
Data de inscrição : 17/02/2012

MensagemAssunto: combinação de funções procv e SE   Qui Fev 23, 2012 2:41 pm

sendspace.com/file/m66ke1

link do arquivo.

preciso debitar as horas de trabalho do total

Grato
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Sex Fev 24, 2012 12:53 pm

Bom dia!!!

Se baseia na planilha que postou e dê mais detalhes.

=SE($E$2:$E$7="projeto1";$B$1-D2)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
eduardoniluiz



Mensagens : 6
Data de inscrição : 17/02/2012

MensagemAssunto: combinação de funções procv e SE   Sex Fev 24, 2012 2:13 pm

Bom dia Alexandrevba

é quase isso que eu preciso,

se olhar na coluna e6 tenho mais um projeto1, preciso que essa fórmula leia todo o intervalo definido e subtraia todos os projeto1.
neste caso seria as celulas e2 e e6.

Muito obrigado pela ajuda.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Sab Fev 25, 2012 1:06 am

Boa noite!!!

Vou precisar de mais detalhes da forma que postei é só arrastar para baixo, caso não seja isso explique com TODOS os detalhes possíveis!! Twisted Evil
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Sab Fev 25, 2012 1:06 am

Boa noite!!!

Vou precisar de mais detalhes da forma que postei é só arrastar para baixo, caso não seja isso explique com TODOS os detalhes possíveis!! Twisted Evil
Voltar ao Topo Ir em baixo
Ver perfil do usuário
eduardoniluiz



Mensagens : 6
Data de inscrição : 17/02/2012

MensagemAssunto: combinação de funções procv e SE   Sab Fev 25, 2012 2:04 am

Alexandrevba

entendi seu raciocinio, posso seguir por ele tambem.

mas minha ideia era a seguinte:
formula para ler a coluna E
E2=projeto1, pego valor de D2=5 e subtraio de B2=50, resultado 45, guardo na G2
E3=projeto3, pego valor de D3=2 e subtraio de B4=50, resultado 48, guardo na H2
E4=projeto2, pego valor de D4=7 e subtraio de B3=50, resultado 43, guardo na I2
E5=projeto2, pego valor de D5=2 e subtraio de

neste caso que estou me perdendo quando entra a segunda vez o mesmo projeto. teria q subtrair de I2 e guardar em I2 novamente para o resultado cair de 43 para 41.

não sei se consegui ser claro, mas foi o melhor q consegui.

Grato pela atenção
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Sab Fev 25, 2012 2:31 am

Boa noite!!

Baixe o anexo e veja se te ajuda..

http://www.sendspace.com/file/7xornk
Voltar ao Topo Ir em baixo
Ver perfil do usuário
eduardoniluiz



Mensagens : 6
Data de inscrição : 17/02/2012

MensagemAssunto: combinação de funções procv e SE   Seg Fev 27, 2012 2:47 pm

Alexandrevba

Muito obrigado pela ajuda, vai me ajuda e muito isso..

agradeço a atenção nesse trabalho.

abraços

ps. não localizei a opção para finalizar o forum, se puder me ajudar novamente.rs.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Seg Fev 27, 2012 3:08 pm

Bom dia!!!

Obrigado pelo retorno e que bom que deu certo!

Vá em seu 1º postagem desse tópico e digite na barra de titulo [RESOLVIDO]

Se não funcionar Vá em EDITAR do seu 1º postagem desse tópico e depois, digite na barra de titulo [RESOLVIDO]
Att..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: [RESOLVIDO] combinação de funções procv e SE   Hoje à(s) 8:56 am

Voltar ao Topo Ir em baixo
 
[RESOLVIDO] combinação de funções procv e SE
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido]pra que serve a função Run game in debug mode do game maker 8
» [Resolvido]como usar a função jump to start por codigo?
» [RESOLVIDO]2 funções utilizando a mesma tecla???
» [Resolvido] Abrir arquivos e automaticamente executar função nele
» [Resolvido]Função Export

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: