Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Consolidação de divs. planilhas com soma

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
karincruz



Mensagens : 4
Data de inscrição : 23/02/2012

MensagemAssunto: Consolidação de divs. planilhas com soma   Qui Fev 23, 2012 10:09 pm

Boa Tarde! Laughing

Estou com um problema e gostaria que me ajudassem a resolve-lo. confused

Tenho um arquivo com 12 planilhas (que poderá aumentar ou diminuir). Em cada planilha existe uma listagem de vários produtos (que se repetem ou não entre elas) com uma quantidade em cada item.
Gostaria que me informassem uma formula para que os produtos repetidos e não repetidos apareçam em uma unica planilha com a soma total (se repetidos ou não)

Se for preciso posso enviar o arquivo.

Grata,

Karin Cruz
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Sex Fev 24, 2012 12:46 pm

Bom dia!!!

Seja Bem Vinda!! cheers

Poste o seu arquivo rabbit
Voltar ao Topo Ir em baixo
Ver perfil do usuário
karincruz



Mensagens : 4
Data de inscrição : 23/02/2012

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Sex Fev 24, 2012 3:30 pm

Obrigada! alien

Poderia me informar um email para enviar em anexo?

Abraço...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Sab Fev 25, 2012 1:46 am

Boa noite!!

Poste em site gratuito, como 4shared ou senspace e outros depois nos mande o link
Voltar ao Topo Ir em baixo
Ver perfil do usuário
karincruz



Mensagens : 4
Data de inscrição : 23/02/2012

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Ter Fev 28, 2012 9:27 pm

Boa tarde!

Demorei mas consegui, hehehe
Segue o link da planilha.

4shared.com/file/yDvs-7xU/Centrais.html?

Abraço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Qua Fev 29, 2012 2:43 pm

Bom dia!!

Na planilha (Plan1), coloque essa formula em C3
Código:
=SOMA(SOMASE('os612'!A:A;A3;'os612'!L:L);SOMASE('os734'!A:A;A3;'os734'!L:L);SOMASE('os810'!A:A;A3;'os810'!L:L);SOMASE('os833'!A:A;A3;'os833'!L:L);SOMASE('os851'!A:A;A3;'os851'!L:L);SOMASE('os852'!A:A;A3;'os852'!L:L);SOMASE('os855'!A:A;A3;'os855'!L:L);SOMASE('os880'!A:A;A3;'os880'!L:L);SOMASE('os819'!A:A;A3;'os819'!L:L);SOMASE('os929'!A:A;A3;'os929'!L:L);SOMASE('os943'!A:A;A3;'os943'!L:L))

Voltar ao Topo Ir em baixo
Ver perfil do usuário
karincruz



Mensagens : 4
Data de inscrição : 23/02/2012

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Qua Fev 29, 2012 3:41 pm

alexandrevba escreveu:
Bom dia!!

Na planilha (Plan1), coloque essa formula em C3
Código:
=SOMA(SOMASE('os612'!A:A;A3;'os612'!L:L);SOMASE('os734'!A:A;A3;'os734'!L:L);SOMASE('os810'!A:A;A3;'os810'!L:L);SOMASE('os833'!A:A;A3;'os833'!L:L);SOMASE('os851'!A:A;A3;'os851'!L:L);SOMASE('os852'!A:A;A3;'os852'!L:L);SOMASE('os855'!A:A;A3;'os855'!L:L);SOMASE('os880'!A:A;A3;'os880'!L:L);SOMASE('os819'!A:A;A3;'os819'!L:L);SOMASE('os929'!A:A;A3;'os929'!L:L);SOMASE('os943'!A:A;A3;'os943'!L:L))


Oiiii

Fiz exatamente como pediu na Plan1 e a celula esta zerada.
Tb não puxou os produtos das demais planilhas.

O que devo fazer?

Abraço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Qui Mar 01, 2012 2:56 am

Boa noite!!!


sem dúvida, em A3 vai ter um código que tem em uma das planilhas nomeadas!!!

Caso esteja vazia ou com código que não tem em nenhuma das abas vai retornar zero!! No

Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Consolidação de divs. planilhas com soma   Hoje à(s) 5:43 pm

Voltar ao Topo Ir em baixo
 
Consolidação de divs. planilhas com soma
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Alinhar divs lado a lado
» [TUTORIAL] Menu de navegação
» Espaço entre menu e div inferior
» Como deixo isso na mesma linha
» Sobre categoria que se retrai

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: