Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
APFMOS2010



Mensagens : 2
Data de inscrição : 01/03/2012

MensagemAssunto: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Qui Mar 01, 2012 4:25 am

olá pessoal, se alguém souber resolver essa situação por favor me ajudem.
É o seguinte, tenho uma planilha assim:


---------------------A------------------B-----------------------C--------------------D
linha 1-------------2-------------------1-------------- célula C1 vazia-------------?
linha 2-------------5-------------------3----------------------12---------------------?
linha 3-------------7-------------------7--------------célula C3 vazia--------------?
linha 4-------------9------------------11-----------------------8---------------------?
linha 5------------12------------------14--------------célula C5 vazia-------------?
linha 6------------16------------------17-----------------------6--------------------?
linha 7------------19----------célula B7 vazia--------célula C7 vazia-------------?
linha 8------------25----------célula B8 vazia--------célula C8 vazia-------------?


Eu preciso criar uma fórmula em D1, D2, D3 ... onde vou querer que se verifique se o valor da célula A1 está entre os valores das células B1 e B2. Se o valor da célula estiver entre os valores das celulas B1 e B2 eu quero que seja lançado o valor da celula C2 na célula D1, se não corresponder, que seja feito nova verificação do valor da célula A1, só que dessa vez entre B3 e B4 e se for verificado que o valor de A1 está entre B2 e B3 que seja lançado o valor da célula C4 na célula D1 , assim sucessivamente. Depois eu faria a mesma verificação para as células A2, A3 ...

Resumindo seria algo assim: Se 2 for maior que 1 e menor que 3, o valor da célula C2, ou seja 12, seja lançado na célula D1.

Espero que eu tenha sido claro,

Se alguém souber agradeço.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Sex Mar 02, 2012 1:30 am

Boa noite!!

Seja bem vindo!! cheers

seria melhor postar uma planilha. poste em um site gratuito como 4Shared ou outros e nos mande o link
Com todos os detalhes possíveis, simule o resultado desejado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Sab Mar 03, 2012 4:48 am

boa noite!!!

Veja
http://www.sendspace.com/file/6trluw
Voltar ao Topo Ir em baixo
Ver perfil do usuário
APFMOS2010



Mensagens : 2
Data de inscrição : 01/03/2012

MensagemAssunto: PEDIDO DE PLANILHA   Dom Mar 04, 2012 4:21 am

ERA EXATAMENTE ISSO QUE EU PRECISAVA, MUITO OBRIGADO CAMARADA. VOCÊ É FERA VELHO.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Dom Mar 04, 2012 3:43 pm

Bom dia!!

Quem que foi resolvido, caso precisar sabe onde solicitar... Laughing

At++++
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Natalia Moreschi



Mensagens : 1
Data de inscrição : 07/08/2012

MensagemAssunto: Como foi resolvido?   Ter Ago 07, 2012 1:36 am

Boa noite.

Acredito que tenho um caso parecido com este e gostaria de ajuda.

Preciso fazer um resumo de parcelas a vencer, nele digito o período desejado e gostaria que ele consultasse as outras abas existentes e retornasse a data que se encaixa no período. Porém com o PROCV não consegui localizar um intervalo de dados dentro de outro.

Tive que fazer duas fórmulas para conseguir esse filtro, segue descrição abaixo:

o intervalo de datas está na planilha "resumo vctos b3 e d3"; Os dados a serem consutados na planilha "Bradesco 237.01", então na planilha de consulta utilizei a seguinte formula:
"=SE(E(F11>='RESUMO VCTOS'!$B$3;'BRADESCO 237.01'!F11<='RESUMO VCTOS'!$D$3);1;0)",
utilizei esse resultado para alimentar o resumo na planilha "resumo vctos" a seguinte fórmula: "=PROCV(1;'BRADESCO 237.01'!$A$11:$F$28;6;"FALSO")"

Gostaria de fazer todo esse procedimento direto no resumo e com uma fórmula só.

Alguém pode me ajudar? Caso sim, me passem como posso encaminhar a planilha para darem uma olhada.

Obrigada.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Ter Ago 07, 2012 3:38 am

Boa noite!!

Seja bem vinda!!
Lhe recomendo abrir seu próprio tópico!!!

seria melhor postar uma planilha. poste em um site gratuito como 4Shared ou outros e nos mande o link
Com todos os detalhes possíveis, simule o resultado desejado!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA   Hoje à(s) 8:23 pm

Voltar ao Topo Ir em baixo
 
LOCALIZAR UM VALOR NUM INTERVALO PARA LANÇAR O VALOR CORRESPONDENTE EM OUTRA CÉLULA
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Colocar valor mínimo no lançamento de dados
» Em busca de sonoplasta para lançamento de jogo
» Manipulação binária de arquivos/memória (Game Maker)
» como enviar valor campo calculado para tabela
» Á como criar uma categoria e nessa categoria,fóruns para somente um valor x de grupos?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: