Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Assunto: Como condicionar um intervalo para as células que possuem =símbolo virar número

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
nancypaes@hotmail.com



Mensagens : 2
Data de inscrição : 06/06/2012

MensagemAssunto: Assunto: Como condicionar um intervalo para as células que possuem =símbolo virar número   Qua Jun 06, 2012 11:13 pm

Boa Tarde!

Preciso de uma ajudinha dos especialistas..

Tenho uma planilha de análise de laboratório conforme modelo abaixo:

A B C D E F G H I
1 01 02 03 04 05 06 MÉDIA MENOR MAIOR
2 >160 >20 18 18,3 45,5

Definições
As colunas até a letra F correspondem a dias corridos de um dado mês.
A linha 2 (dois) corresponde aos resultados analíticos de um dado parâmetro.
Na linha 2 (dois) tenho células com sinal de maior, com números inteiros, decimais e em branco (caso não haja a análise do parâmetro neste dado dia)

Meu problema é com o sinal de maior eu não consigo calcular a média, nem o maior e o menor valor, então consegui transformar o número maior em apenas o número (ex: >150 = 150), beleza é o que eu queria!, porém não consigo condicionar para que ele só tire o primeiro caractér, (no meu caso o sina de maior(>)) mantendo o resto como um número apenas, das células que possuem o sinal de maior.
Quero que na linha de baixo repetir o numero se ele não tiver o sinal de maior e se ele tiver o sinal de maior tirar o sinal.

GROSSEIRAMENTE:
=SE(A2 = NÃO POSSUIR O SINAL DE MAIOR; A2; MUDAR(1;1;””))

Ficando então:
A B C D E F G H I
1 01 02 03 04 05 06 MÉDIA MENOR MAIOR
2 >160 >20 18 18,3 45,5
3 160 20 18 18,3 - 45,5 =média(A3:F3) 18

* A média deverá ser = (160+20+18+18,3+45,5)/5, não deverá ser dividido por 6, já que a célula G2 está em branco (não é zero).

Alguém pode me ajudar?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Patropi



Mensagens : 49
Data de inscrição : 14/06/2012
Localização : Campo Mourão - PR

MensagemAssunto: Re: Assunto: Como condicionar um intervalo para as células que possuem =símbolo virar número   Qui Jun 14, 2012 3:18 am

Boa noite Nancy

Já respondi no fórum Abril.

Um abraço.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Assunto: Como condicionar um intervalo para as células que possuem =símbolo virar número
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido] Como configuro o meu para aparecer as categorias em vez dos topicos?
» Como retornar uma template para padrão
» Como eu faço para os membros do meu forum ver imagens e links ?
» como fazer um topico para regras
» Como remover o atalho para os fóruns da categoria

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: