Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 CORRESP em lista com repetições

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
rodrigoavf



Mensagens : 1
Data de inscrição : 18/06/2012
Idade : 27
Localização : Canoas - RS

MensagemAssunto: CORRESP em lista com repetições   Ter Jun 19, 2012 12:03 am

Olá, primeira vez num fórum (de todos os tempos) tenho uma tabela da seguinte forme
A B
1 Ativo Valor
2 BCD 4,8
3DFG 4,8
4ERT 7
5EIU 5,2
6EGJ 5
7HTR 7

Suponhamos que nas célula D1, D2, D3 e D4 eu utilize a seguintes funções para encontrar respectivamente os 2 maiores e menores valores da coluna B:
=MAIOR(B:B;1)
=MAIOR(B:B;2)
=MENOR(B:B;1)
=MENOR(B:B;2)

E então nas célula E1 a E4 eu utilize a seguinte fórmula para que me retorne qual é o ativo que corresponde ao maior valor e o menor valor encontrado na etapa anterior:
=ÍNDICE(A:A;CORRESP(D1;B:B;0))
=ÍNDICE(A:A;CORRESP(D2;B:B;0))
=ÍNDICE(A:A;CORRESP(D3;B:B;0))
=ÍNDICE(A:A;CORRESP(D4;B:B;0))

O PROBLEMA
Dá forma como está, a formula da etapa anterior retorna sempre o mesmo ativo, ou seja considera que o primeiro e o segundo ativo com maior (ou menor) valor são o mesmo, visto que alguns valores se repetem na coluna B. Ou seja fica assim:
=ÍNDICE(A:A;CORRESP(D1;B:B;0)) -> ERT
=ÍNDICE(A:A;CORRESP(D2;B:B;0)) -> ERT
=ÍNDICE(A:A;CORRESP(D3;B:B;0)) -> BCD
=ÍNDICE(A:A;CORRESP(D4;B:B;0)) -> BCD

Quando o esperado seria:
=ÍNDICE(A:A;CORRESP(D1;B:B;0)) -> ERT
=ÍNDICE(A:A;CORRESP(D2;B:B;0)) -> HRT
=ÍNDICE(A:A;CORRESP(D3;B:B;0)) -> BCD
=ÍNDICE(A:A;CORRESP(D4;B:B;0)) -> DFG

Como solucionar este problema? Alguém pode me ajudar?

Agradeço desde já, abraço a todos!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
CORRESP em lista com repetições
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [DUVIDA] lista de contatos
» [Link]Lista de sites de stocks!
» Lista de sites com Efeitos Sonoros
» Lista com rolagem
» [XCREATOR] [ENGINE] Manipulação de Lista de Strings

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: