Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Problema com escala - Sabado em um Mês e Domingo no proximo

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
fablics



Mensagens : 2
Data de inscrição : 06/08/2012

MensagemAssunto: Problema com escala - Sabado em um Mês e Domingo no proximo   Seg Ago 06, 2012 5:02 pm

Pessoal, estou com um problema para automatizar uma planilha onde o funcionário em um mes folga no domingo e no outro no sábado, quando a folga é na primeira semana do mês fica fácil, o problema é quando a folga cai no segundo, terceiro e quarto final de semana.
Quanto a alteração do mês eu faço uma verificação simples se o mês é par ou impar e executo a descoberta do dia da semana com DIA.DA.SEMANA.

=SE(ÍMPAR(MÊS(Setembro!C1));SE(PROCV(Setembro!D4;Controle!A1:Q53;13;FALSO)=DIA.DA.SEMANA(Setembro!AN1;2);"Folga";"");100), o 100 é só para validação de resultado pois as fomulas são inclusas.

Se alguem puder me ajudar agradeço desde já
Voltar ao Topo Ir em baixo
Ver perfil do usuário
fablics



Mensagens : 2
Data de inscrição : 06/08/2012

MensagemAssunto: Maiores informações   Seg Ago 06, 2012 5:49 pm

A planilha de controle tem 14 colunas e linhas para cada funcionário sendo:
Normais Reduzido
Funcionário, Codigo, Folga, Dia Reduzido, Horários Horários Sábado, Domingo
E1 S1 E2 S2 E1 S1 E2 S2

E= entrada S=Saída
a formula onde incluirei a validação de sábado e domingo está da seguinte maneira:

=SE((ESCOLHER(DIA.DA.SEMANA($E$1;2);"segunda-feira";"terça-feira";"quarta-feira";"quinta-feira";"sexta-feira";"sábado";"domingo"))=(PROCV($D4;Controle!$A$2:$Q$53;4;FALSO));PROCV($D4;Controle!$A$2:$Q$53;9;FALSO);SE((ESCOLHER(DIA.DA.SEMANA($E$1;2);"segunda-feira";"terça-feira";"quarta-feira";"quinta-feira";"sexta-feira";"sábado";"domingo"))=(PROCV($D4;Controle!$A$2:$Q$53;3;FALSO));"Folga";PROCV($D4;Controle!$A$2:$Q$53;5;FALSO)))
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Problema com escala - Sabado em um Mês e Domingo no proximo
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Problema com arquivos DOC e PDF
» Problema com carregamento de celular?
» Grande problema a 2T
» [Resolvido]Problema com terreno acidentado
» Problema de sinal

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: