Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Código para Desbloqueio de Celula

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
rafasg



Mensagens : 8
Data de inscrição : 10/08/2012

MensagemAssunto: Código para Desbloqueio de Celula   Seg Ago 13, 2012 2:11 pm

Boa dia pessoal, preciso de ajuda. Tenho uma planilha em que a célula preço precisar estar bloqueada para digitação, porém, se o código do item iniciar com 3, a célula preço poderá ser altera.

código descrição und. preço
123 papel A4 pc 10,00 -> esse valor puxa do banco através do procv
221 papel Carta pc 9,00 -> esse valor puxa do banco através do procv
321 folha plática und 0,16 -> esse pode ser alterado

Alguem conhece algum código que faça isso?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Código para Desbloqueio de Celula   Qua Ago 15, 2012 4:17 am

Boa noite!!
Para C2 e D2 ...e
Considerando que em E2 eu tenho a formula
Citação :
=SE(ESQUERDA($C$2;1)*1=3;1;0)
Então no campo de código da planilha use..
Código:
Private Sub Worksheet_Change(ByVal Target As Range)
    Application.EnableEvents = False
    With ActiveSheet
        .Unprotect
        If .Range("E2").Value = 0 Then
            .Range("D2").Locked = True
        Else
            .Range("D2").Locked = False
        End If
        .Protect
    End With
    Application.EnableEvents = True
End Sub

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rafasg



Mensagens : 8
Data de inscrição : 10/08/2012

MensagemAssunto: Re: Código para Desbloqueio de Celula   Qua Ago 15, 2012 1:59 pm

Obrigado pela ajuda, mas ainda não consegui fazer funcionar.
As celulas estão todas bloqueadas (com exceção das celulas Codigo A2:A15) e a planilha protegida.
Coloquei o código na planilha e não está destravando a celula preço(C2), quando a celula código(A2) iniciar com 3.
Tenho a formula =SE(ESQUERDA($A$2;1)*1=3;1;0) na celula (D2).
Agradeço se puder me ajudar.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Código para Desbloqueio de Celula   Qui Ago 16, 2012 2:11 am

Boa noite!!

Poste seu arquivo em site gratuito como sendspace e outros e nos mande o link


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rafasg



Mensagens : 8
Data de inscrição : 10/08/2012

MensagemAssunto: Re: Código para Desbloqueio de Celula   Qui Ago 16, 2012 5:24 pm

Bom dia, segue o link

sendspace.com/file/vgxkgn
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Código para Desbloqueio de Celula   Sex Ago 17, 2012 4:44 am

Boa noite!!

Para isso terei que antes selecionar a coluna 'L' e desbloquea-la.

Diga a senha!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
rafasg



Mensagens : 8
Data de inscrição : 10/08/2012

MensagemAssunto: Re: Código para Desbloqueio de Celula   Sex Ago 17, 2012 1:41 pm

Bom dia,

a senha é: teste
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Código para Desbloqueio de Celula   Hoje à(s) 8:52 am

Voltar ao Topo Ir em baixo
 
Código para Desbloqueio de Celula
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Código para descobrir IP
» Código para música
» Inserir código para cursor de mouse personalizado
» Código para background
» o Network Lock está em ON no meu s8500b, como faso para atualizar o bada para 2.0

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: