Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Soma por Condição com Comparação

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Murillo



Mensagens : 2
Data de inscrição : 02/09/2012

MensagemAssunto: Soma por Condição com Comparação   Dom Set 02, 2012 12:19 am

Galera, por favor, poderiam me ajudar a formatar formulas que satisfaçam as seguintes condições?

CONDIÇÕES PARA A0
Quando A0 <=2,0 somar todos os valores de A0 <=2,0. Em seguida dividir pela qtd total de variaveis da lista A0. E após, multiplicar por 100.

Quando A0 >2,0 e <=4,0 somar todos os valores de A0 >2,0 e <=4,0. Em seguida dividir pelatotal de variaveis da lista A0. E após, multiplicar por 100.

Quando A0 >4,0 somar todos os valores de A0 >4,0. Em seguida dividir pela qtd total de variaveis da lista A0. E após, multiplicar por 100.

Obs: A0 é uma lista contedo valores numericos.

Desde já, agradeço!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Soma por Condição com Comparação   Dom Set 02, 2012 1:12 am

BOa noite!!

Explique melhor...
O que quer dizer com...
Citação :
Em seguida dividir pela qtd total de variaveis da lista A0

Att confused
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Murillo



Mensagens : 2
Data de inscrição : 02/09/2012

MensagemAssunto: Soma por Condição com Comparação   Dom Set 02, 2012 1:58 am

alexandrevba

É a quantidade total de variáveis que tenho na tabela. Por exemplo: 50 variáveis. Então utilizar "50" para dividir o valor total da soma.

Facilitou?

Grato pelo retorno.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Soma por Condição com Comparação   Dom Set 02, 2012 3:32 am

Boa noite!!!

Faça os teste...
Código:
=SE(SOMA(A1:A8)<=2;(SOMA(A1:A8)/CONT.VALORES(A1:A8))*100;SE(E(SOMA(A1:A8)>=2,1;SOMA(A1:A8)<=4);(SOMA(A1:A8)/CONT.VALORES(A1:A8))*100;SE(SOMA(A1:A8)>4;(SOMA(A1:A8)/CONT.VALORES(A1:A8))*100;"")))

drunken

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Soma por Condição com Comparação   Hoje à(s) 8:58 pm

Voltar ao Topo Ir em baixo
 
Soma por Condição com Comparação
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Reconhecimento e comparação de voz(audio)
» Como implementar coisas nas condições de utilizações do fórum
» Duas condições SE em um mesmo campo calculado - Outra dúvida
» Palhaçada da Samsung
» Bit9 divulga os 13 smartphones mais vulneráveis de 2011

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: