Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Detectar cruzamento de valores

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Adão Smith



Mensagens : 2
Data de inscrição : 09/10/2012

MensagemAssunto: Detectar cruzamento de valores   Ter Out 09, 2012 7:59 am

Boa Noite!
estou com a seguinte dúvida:
Tenho duas séries temporais, que são duas médias. Uma aritmética e outra exponencial.
Quero descobrir um jeito de contar os cruzamentos destes valores, ou seja quando uma série cruza pela outra.
Detalhe não posso usar o recurso do gráfico para detectar os cruzamentos.
Como faço para detectar esses cruzamentos? e contá-los ?
Segue o exemplo:

Duas colunas MA e ME

MA -------- ME
6,57 ----- 6,51
6,53 ----- 6,52
6,51 ----- 6,52
6,48 ----- 6,51
6,36 ----- 6,46
6,29 ----- 6,41
6,25 ----- 6,37

Na linha sublinhada fica fácil identificar o cruzamento das médias, mas como possuo uma série com mais de 2 mil linhas não tem como ficar contando na mão, e não posso usar recurso gráfico.

Como detectar os cruzamentos e como contá-los?
Ajuda por favor!

Desde já muito obrigado, abraço.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Detectar cruzamento de valores   Qua Out 10, 2012 3:00 am

Boa noite!!

Eu não entendi mas...
=SE($B2-$A2=0,00999999999999979;"Cruzamento";"")

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Adão Smith



Mensagens : 2
Data de inscrição : 09/10/2012

MensagemAssunto: Re: Detectar cruzamento de valores   Qua Out 10, 2012 6:45 am

alexandrevba escreveu:
Boa noite!!

Eu não entendi mas...
=SE($B2-$A2=0,00999999999999979;"Cruzamento";"")

Att


Não era bem o que eu queria, mas estipulando valores com a função SE eu crio um parâmetro para usar no Stata, um programa que tenho mais conhecimento.

Me foi muito útil, obrigado!
Abraço
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Detectar cruzamento de valores   Hoje à(s) 10:15 pm

Voltar ao Topo Ir em baixo
 
Detectar cruzamento de valores
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Guardar valores de variaveis locais - -'
» Como detectar multicontas?
» È possível unir tópicos e mensagens á seus valores?
» Formula para interpolação de valores
» [bada][S8500][gratuito] Magnit

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: