Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 [Resolvido] Encontrar primeiro número diferente de zero e contar zeros

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
racristofolini



Mensagens : 2
Data de inscrição : 03/11/2012
Idade : 31

MensagemAssunto: [Resolvido] Encontrar primeiro número diferente de zero e contar zeros   Sab Nov 03, 2012 4:43 pm

Olá;

Possuo uma coluna (A) com aproximadamente 500 linhas, como no exemplo resumido abaixo.


L|Col A
1 | 0
2 | 0
3 | 0 <-- Estes 5 primeiros zeros são o resultado que quero chegar na Fórmula 1 (explicada abaixo)
4 | 0
5 | 0
6 | 50 <-- Aqui está o resultado que quero chegar na Fórmula 2 (explicada abaixo)
7 | 52
8 | 49
9 | 48
10 | 0
11 | 0
12 | 0
13 | 0
14 | 48

Bom, estou precisando destes dois cálculos:
FÓRMULA 1: preciso de uma fórmula que me retorne o número de células que sejam iguais a zero, mas contando apenas até o primeira célula que seja
diferente de zero. Explicando melhor: No exemplo acima, como na célula A6 existe um número diferente de zero (50), deve parar de contar
os zeros alí, e não contar os zeros da coluna inteira (A10 até A13). Ou seja, a resposta do exemplo deve dar 5.

FÓRMULA 2: preciso de uma fórmula que me retorne sempre o valor da PRIMEIRA célula diferente de zero, no exemplo acima deveria retornar 50 (célula A6).

Não entendo muito de VBA, mas se a solução for só em VBA, pode ser também.
Ví que tem bastante gente entendida por aqui, por estou recorrendo a vocês, mas também darei minha contribuição ao fórum sempre que for possível.

Agradeço desde já.



Última edição por racristofolini em Seg Nov 05, 2012 3:34 pm, editado 1 vez(es)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: [Resolvido] Encontrar primeiro número diferente de zero e contar zeros   Sab Nov 03, 2012 10:47 pm

Boa tarde!!

Isso deve resolver...
Para contar os zeros na coluna=CORRESP(1;ÍNDICE(--(A2:A20>0);0);0)-1

Qual o primeiro número maior que zero=ÍNDICE(A2:A20;CORRESP(1;ÍNDICE(--(A2:A20>0);0);0);1)
Voltar ao Topo Ir em baixo
Ver perfil do usuário
racristofolini



Mensagens : 2
Data de inscrição : 03/11/2012
Idade : 31

MensagemAssunto: Resolvido   Seg Nov 05, 2012 3:36 pm

Olá Alexandre;

era exatamente o que eu precisava, muito obrigado.
Podem fechar o tópico, cálculo resolvido.

Voltar ao Topo Ir em baixo
Ver perfil do usuário
hugo75



Mensagens : 9
Data de inscrição : 16/09/2012

MensagemAssunto: Re: [Resolvido] Encontrar primeiro número diferente de zero e contar zeros   Seg Nov 05, 2012 6:50 pm

alexandrevba escreveu:
Boa tarde!!

Isso deve resolver...
Para contar os zeros na coluna=CORRESP(1;ÍNDICE(--(A2:A20>0);0);0)-1

Qual o primeiro número maior que zero=ÍNDICE(A2:A20;CORRESP(1;ÍNDICE(--(A2:A20>0);0);0);1)

Senão for muito incomodo pode explicar o que faz os "--" dentro do índice?
Obrigado Very Happy
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: [Resolvido] Encontrar primeiro número diferente de zero e contar zeros   Hoje à(s) 1:34 pm

Voltar ao Topo Ir em baixo
 
[Resolvido] Encontrar primeiro número diferente de zero e contar zeros
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido] Menu com seta diferente
» [Resolvido]Retornar número da semana a partir de uma Data
» [Resolvido]Formatar Número
» [RESOLVIDO]Como colocar o player em primeiro plano
» [Resolvido] [Resolvido] Como colocar barrinhas/ranks para indicar o número de posts

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: