Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Ajuda com Formula (intervalo +1)

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
marciarv



Mensagens : 5
Data de inscrição : 25/05/2013

MensagemAssunto: Ajuda com Formula (intervalo +1)   Sab Maio 25, 2013 3:10 am

Boa noite pessoal,
Estou precisando de uma grande ajuda, pois tenho uma planilha onde realizo um cadastro de atividades diárias, e nela tenho um campo onde tem que verificar os valores que contem repetidos e se houver ela pega o numero da sequencia e soma +1. Exemplo
A B C
Sequencia -- data -- atividade
1 ------ 02\04\2013 --- lavou o carro
1 ------ 03\04\2013 --- foi ao mercado
1 ------ 15\04\2013 --- Limpou os tapetes
2 ------ 21\04\2013 --- lavou o carro
2 ------ 25\04\2013 --- foi ao mercado

Quero que quando a atividade se repita ele consiga pegar o número atual e somar +1. Eu estou usando essa formula
=SE(C2=(C1:C200);B1+1;1), mas com ela eu só consigo realizar a soma quando o lançamento fico logo um abaixo do outro e se for lançamentos em colunas abaixo como a do exemplo ele não consegue somar e fica sempre me mostrando sequencia 1.

Se alguém puder me dar uma luz de como fazer isso eu ficaria muito grata.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Sab Maio 25, 2013 7:59 pm

Boa tarde!!

Poste seu arquivo em site gratuito e nos mande link!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marciarv



Mensagens : 5
Data de inscrição : 25/05/2013

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Sab Maio 25, 2013 9:34 pm

Boa tarde,
primeiramente obrigado por responder, e segue o link para download do aquivo.

rapidshare.com/files/1380294601/teste.xlsx

lá você ira verificar que ele só soma a sequencia quando um está logo abaixo o outro, mas eu preciso que ele some independente de onde esteja lançado a atividade. Espero que tenha conseguido passar o meu problema.
Qualquer dúvida é só dizer.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Sab Maio 25, 2013 11:40 pm

Boa tarde!!

Você tem cadstro no sendspace ou 4shared?

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marciarv



Mensagens : 5
Data de inscrição : 25/05/2013

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Dom Maio 26, 2013 10:30 pm

Boa tarde,

Sim eu tenho cadastro no 4shared, e add lá a planilha, segue o link.

.4shared.com/file/HGmr6WPy/teste.html


Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Seg Maio 27, 2013 12:33 am

Boa noite!!

Eu naõ sei se eu entendi..

coloque a formula em b2
Código:
=IF(C2<>"++";SUMPRODUCT(($C$2:$C$5000<>"")/COUNTIF($C$2:$C$5000;C2&""));"")

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marciarv



Mensagens : 5
Data de inscrição : 25/05/2013

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Seg Maio 27, 2013 3:20 pm

Bom dia Alexandre,

Coloquei a formula em B2, como você orientou mas infelizmente ela dá erro
Sad , será que não teria outra maneira.

E obrigado por estar me ajudando.

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Ter Maio 28, 2013 3:22 am

Boa noite!!

Geralmente quando eu não entendo a explicação (defeito meu), eu abandono o tópico mesmo sabendo que poderia ajudar a solucionar a dúvida.

Vamos aguardar outra pessoa nos ajudar, eu sinto muito!! pale
Voltar ao Topo Ir em baixo
Ver perfil do usuário
BrunoF



Mensagens : 9
Data de inscrição : 26/04/2013

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Ter Maio 28, 2013 5:21 pm

Marcia,

Considerando que a sequencia esta na coluna A, a data na B e a descrição na C:

coloque está formula na a2 (considerando que sua planilha tem um cabeçalho na linha 1) e replique para as demais e veja se era isso que esperava.

=SE(C2<>"";CONT.SE($C$2:$C2;C2);"-")

Veja se atende.

Att,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
marciarv



Mensagens : 5
Data de inscrição : 25/05/2013

MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Qua Maio 29, 2013 3:13 am

Boa noite,

Primeiramente quero agradecer a vc Alexandre, pela tentativa de querer me ajudar e isso pra mim já vale e muito, pois eu tb não consegui passar claramente qual era a a minha necessidade e sei que isso dificulta bastante mas obrigado mesmo.

E Bruno fiz os teste aqui e sua formula é exatamente o que eu estava precisando e foi show de bola e sem palavras para agradecer pois isso irá me ajudar e muito.

OBRIGADO A TODOS!!! hehehehehe....
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Ajuda com Formula (intervalo +1)   Hoje à(s) 5:43 pm

Voltar ao Topo Ir em baixo
 
Ajuda com Formula (intervalo +1)
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Ajuda Ndrive
» ajuda ajuda kies
» [Ajuda]Como fazer sistema de dinheiro "money"
» [resolvido] Intervalo entre disparos
» [Ajuda] Como faço isso?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: