Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Filtro de Nomes

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Filtro de Nomes   Dom Dez 01, 2013 2:13 pm

Olá pessoal! por favor, estou com uma dúvida para filtrar alguns nomes de uma planilha (tem o link de uma planilha exemplo abaixo). Aparentemente é simples, mas tenho uma relação de nomes e uma quantidade valor para cada nome. Algo do tipo:
Coluna A Coluna B
Ana 5
Bernado 1
Ana 2
Ana 4
Bernardo 3

Sendo que o resultado deve ser:
Ana 11
Bernardo 4

E chamei de filtrar os nomes que compõe a relação e somar os valores em outra coluna.
Postei a planilha exemplo no link a seguir:
sendspace.com/file/qgi009
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Dom Dez 01, 2013 11:41 pm

Boa tarde!!

Veja se ajuda...
http://www.sendspace.com/file/e8dkdp

Att


Voltar ao Topo Ir em baixo
Ver perfil do usuário
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Retorno sobre o filtro   Ter Dez 03, 2013 3:33 am

Olá. Obrigado pelo retorno, mas pelo meu trabalho, preciso que o filtro fique em uma única planilha e também não seja necessário um botão para executar.
Poderia me ajudar? Há algum tipo de fórmula que posso usar? ou macro na mesma planilha?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Ter Dez 03, 2013 3:40 am

Boa noite!!

Veja se te ajuda...
http://www.sendspace.com/file/8cngf4

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Retorno   Ter Dez 03, 2013 4:29 am

Deu Certo! Obrigado. E se eu colocasse outras colunas com mais bichos. Como ficaria a fórmula com a relação filtros gerais?
Veja no anexo:


sendspace.com/file/994rv8
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Ter Dez 03, 2013 1:01 pm

Bom dia!!

Neste caso eu preferia fazer via VBA.

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Ok   Ter Dez 03, 2013 1:20 pm

Ok. mas como ficaria?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Ter Dez 03, 2013 2:12 pm

Bom dia!!

Veja se ajuda.
http://www.sendspace.com/file/8f27oj

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Mais uma dúvida sobre o filtro   Dom Dez 08, 2013 3:17 am

Por favor, a fórmula =SEERRO(ÍNDICE($D$5:$D$184;CORRESP(0;CONT.SE($V$4:V6;$D$5:$D$184);0));"")
deu certo. Obrigadão.
Mas como fazer para que a fórmula matricial não traga (ou seja conte) os itens com zero ou em branco??

Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Dom Dez 08, 2013 11:49 am

Bom dia!!

Você montar um exemplo em um arquivo modelo om o problema que está ocorrendo?


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
santa.ars



Mensagens : 136
Data de inscrição : 07/09/2011

MensagemAssunto: Exemplo de planilha para não colocar filtros   Dom Dez 08, 2013 1:34 pm

Olá,
conforme sugestão coloquei o arquivo no link abaixo. Na coluna verde, tem a fórmula matricial: =SEERRO(ÍNDICE($A$5:$A$25;CORRESP(0;CONT.SE($L$4:L4;$A$5:$A$25);0));"")

ele busca os nomes da coluna amarela, mas não quero que venha o zero (0) e nem espaço em branco, entendeu?


sendspace.com/file/2f2mnw


Agradeço desde já
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Filtro de Nomes   Dom Dez 08, 2013 3:56 pm

Bom dia!!

Veja se é isso.
http://www.sendspace.com/file/dpsi5k


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Filtro de Nomes   Hoje à(s) 10:50 pm

Voltar ao Topo Ir em baixo
 
Filtro de Nomes
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Barulho caixa do filtro ar
» Efeito nos nomes
» modificar pontuaçao rank numeros para rank nomes
» Codigo para meter negrito dos nomes dos usarios
» Icones e Nomes de Categorias de Forum

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: