Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
hebersonsette



Mensagens : 2
Data de inscrição : 26/01/2014

MensagemAssunto: Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?   Dom Jan 26, 2014 3:43 am

Olá a todos!

Sou iniciante em VBA e gostaria que me ajudassem com a seguinte questão:

Tenho um código em VBA que cria as formulas em determinadas células, porém após a execução do código eu tenho que pressionar manualmente a tecla F2 e depois a tecla enter para atualizar as células que contem as formulas.

Como executo isso em VBA ?

Grato por me ajudar.


Código:
Private Sub CalculaEstats_Click()
'-------------------------------
'Adicionas as formulas
'-------------------------------
    With ActiveSheet

'As fórmulas será criadas na planilha

        .Range("D2").Formula = "=CONT.NÚM(" & ActiveWindow.Selection.Address & ")"
        .Range("D3").Formula = "=MÍNIMO(" & ActiveWindow.Selection.Address & ")"
        .Range("D4").Formula = "=MÁXIMO(" & ActiveWindow.Selection.Address & ")"
        .Range("D5").Formula = "=SOMA(" & ActiveWindow.Selection.Address & ")"
        .Range("D6").Formula = "=MÉDIA(" & ActiveWindow.Selection.Address & ")"
        .Range("D7").Formula = "=DESVPAD(" & ActiveWindow.Selection.Address & ")"
'----------------------
'Adiciona os rótulos
'----------------------
        .Range("C2").Value = "Contar:"
        .Range("C3").Value = "Mínimo:"
        .Range("C4").Value = "Máximo:"
        .Range("C5").Value = "Somar"
        .Range("C6").Value = "Média:"
        .Range("C7").Value = "Desvio Padrão:"
        .Range("C2:D7").Select
    End With
'-----------------------------
'Formata as células
'-----------------------------
    With Selection
        .Font.Size = 16
        .Font.Bold = True
        .Font.Color = vbBlue
        .Font.Name = "Arial"
        .Columns.AutoFit
        .Interior.Color = vbWhite
        .Borders.Weight = xlThick
        .Borders.Color = vbRed
    End With
'-----------------------------
'Formata os rótulos
'-----------------------------
    With Selection
        .Font.Size = 16
        .Font.Bold = True
        .Font.Color = vbBlue
        .Font.Name = "Arial"
        .Columns.AutoFit
        .Interior.Color = vbWhite
        .Borders.Weight = xlThick
        .Borders.Color = vbRed
    End With
        Range("A1").Select
End Sub


Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?   Dom Jan 26, 2014 1:52 pm

Bom dia!!

Porque não tenta assim?
Código:
.Range("D2").Formula = "=COUNT(E2)"
        .Range("D3").Formula = "=MAX(E6)"
        .Range("D4").Formula = "=MIN(E3)"
        .Range("D5").Formula = "=SUM(E4)"
        .Range("D6").Formula = "=AVERAGE(E5)"
        .Range("D7").Formula = "=STDEV(D2:D6)"
Favor editar as células referentes ao local desejado.

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
hebersonsette



Mensagens : 2
Data de inscrição : 26/01/2014

MensagemAssunto: Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?   Dom Jan 26, 2014 3:55 pm

Olá alexandrevba!

Muito grato pela pronta resposta.

O grande detalhe é justamente este, eu estou usando a instrução & ActiveWindow.Selection.Address & e por usá-la acontece o problema para o qual estou pedindo ajuda.

As formulas são calculadas com base na seleção das células que estão na intervalo A2:A17, sendo assim eu posso com o mouse selecionar quaisquer células nesta faixa.

Estou aprendendo VBA e estou usando um livro em inglês e são várias as dificuldades, uma delas são as funções que no livro estão no idioma en-us e o meu EXCEL é no idioma pt-br, sendo assim tenho que fazer a tradução das funções.

Mas vamos caminhando, pois com foco, determinação e sobretudo sabendo onde queremos chegar vou aprendendo VBA.

Mas uma vez grato pela ajuda!

Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?   Seg Jan 27, 2014 1:07 am

Boa noite!!

Então minha dica não te ajuda em nada?

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?   Hoje à(s) 8:57 pm

Voltar ao Topo Ir em baixo
 
Como executar via vba o pressionamento da tecla F2 e enter para atualizar fórmulas?
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Script] Exec: executar código gml de um arq. txt
» Como atualizar pra 1.2
» como colocar esse carregamento no indice
» Como mudar a cor do fundo da caixa de texto
» Como arrumar meu html?

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: