Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Retornar número da 1a. célula não vazia

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
micklennon



Mensagens : 4
Data de inscrição : 09/04/2012

MensagemAssunto: Retornar número da 1a. célula não vazia   Sex Maio 23, 2014 2:48 pm

Olá,
Tenho uma planilha contendo linhas com números não ordenados e preciso de uma fórmula que me retorne o valor do número contido na 1a. célula não vazia numa determina linha.

Exemplo:

|  A  |  B  |  C  |  D  |  E  |  F  |  G  |
|___|___|  77 | 81 |___| 75 | 63 |

Na Linha acima, preciso de uma fórmula de que retorno o valor 77, que o número contido na 1a. célula não vaiza na linha.

Abraço,
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Retornar número da 1a. célula não vazia   Sex Maio 23, 2014 7:53 pm

Boa tarde!!

Considerando a linha 1, use uma formula matricial!!!!
Código:
=ÍNDICE(A1:G1;CORRESP(FALSO;É.CÉL.VAZIA(A1:G1);1))
Para que a formula matricial funcione, aperte as teclas Shift+Ctrl+Enter.


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
micklennon



Mensagens : 4
Data de inscrição : 09/04/2012

MensagemAssunto: Deu certo.... mas nem tanto!   Sab Maio 24, 2014 9:48 pm

A fórmula funciona, desde que as células "vazias" sejam realmente vazias. No entanto, no meu caso, as células "vazias" possuem fórmulas que podem gerar células vazias.

Entenderam???? hehehehe
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Retornar número da 1a. célula não vazia   Dom Maio 25, 2014 6:39 pm

Boa tarde!!

Veja
http://www.sendspace.com/file/025ljn

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
micklennon



Mensagens : 4
Data de inscrição : 09/04/2012

MensagemAssunto: Re: Retornar número da 1a. célula não vazia   Seg Maio 26, 2014 5:47 pm

Funcionou perfeitamente. Obrigado!
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Retornar número da 1a. célula não vazia   Seg Maio 26, 2014 7:37 pm

Boa tarde!!

Eu fico feliz por ajudar!!

Att Laughing 
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Retornar número da 1a. célula não vazia   Hoje à(s) 8:53 am

Voltar ao Topo Ir em baixo
 
Retornar número da 1a. célula não vazia
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» [Resolvido]Retornar número da semana a partir de uma Data
» Como ver Número de Mensagens já enviadas no Wave?
» Como retornar uma template para padrão
» Proposta importante: Aumento de número de páginas
» Retornar o numero de novas mensagens privadas

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Usuários Básico :: Excel Básico-
Ir para: