Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 função somase

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
fer_oliver



Mensagens : 2
Data de inscrição : 29/06/2014
Idade : 37
Localização : Apucarana, Pr

MensagemAssunto: função somase   Dom Jun 29, 2014 11:27 pm

Boa tarde,

por favor, me ajudem

Preciso somar o total dos títulos vencidos nas seguintes condições:

dias vencidos

0 a 30 dias;
31 a 60 dias;
61 a 90 dias;
91 a 120 dias;
121 a 150 dias
151 a 180 dias
com mais de 180 dias;


segue abaixo:



Nr Doc Dt Emis Dt Venc Prazo Atraso SITUAÇÃO Parc. Vl. Saldo Cd. Razão Social Status
31322 15/05/2014 15/07/2014 61 16 à vencer 1 R$ 5.197,41 34 CRESIO ROMAGNOLI AB
31574 27/05/2014 15/07/2014 49 16 à vencer 1 R$ 6.111,79 34 CRESIO ROMAGNOLI AB
31016 02/05/2014 15/07/2014 74 16 à vencer 1 R$ 12.554,33 34 CRESIO ROMAGNOLI AB
31574 27/05/2014 15/08/2014 80 47 à vencer 2 R$ 6.111,79 34 CRESIO ROMAGNOLI AB
29100 05/02/2014 28/03/2014 51 -93 vencido 1 R$ 948,00 72 WESLEI DE OLIVEIRA RIBEIRO AB
29964 14/03/2014 28/05/2014 75 -32 vencido 1 R$ 971,95 72 WESLEI DE OLIVEIRA RIBEIRO AB
30196 26/03/2014 28/05/2014 63 -32 vencido 1 R$ 3.970,00 72 WESLEI DE OLIVEIRA RIBEIRO AB
31050 05/05/2014 28/06/2014 54 -1 vencido 1 R$ 4.588,48 72 WESLEI DE OLIVEIRA RIBEIRO AB
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: função somase   Ter Jul 01, 2014 3:54 pm

Bom dia!!

Veja se é isso.
https://www.sendspace.com/file/xz0kn1

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
consultorxls



Mensagens : 2
Data de inscrição : 08/07/2014

MensagemAssunto: Olá tudo bem?   Ter Jul 08, 2014 9:41 pm

Boa tarde,

segue sua resposta.

Abra uma nova coluna F e inclua a formula abaixo:
=SE(E2>0;"À VENCER";SE(E(E2<=0;E2>=-30);"range1";SE(E(E2<-30;E2>=-60);"range2";SE(E(E2<-60;E2>=-90);"range3";SE(E(E2<-90;E2>=-120);"range4";SE(E(E2<-120;E2>=-150);"range5";SE(E(E2<-150;E2>=-180);"range6";SE(E2<-180;"range7";"sem range"))))))))

Coluna "E" e "F" ficará da seguinte forma

Atraso TIPO DE VENCIMENTO
16       À VENCER
16       À VENCER
16       À VENCER
47       À VENCER
-93      range4
-32      range2
-32       range2
-1 range1


Na linha A14 cole especial os valores da coluna F e remova os duplicados.
Ficando da seguinte forma

Criei varios tipos de vencimento exemplo: range1 (0 -30 dias), range 7 (acima de 180 dias)
À VENCER    Acima de 30
range1        0 - 30
range2        31 - 60
range3        61 - 90
range4        91 - 120
range5      121 - 150
range6      151 - 180
range7      A MAIS 180

Na celula C14 copie a formula do somase
=SOMASE($F$2:$J$9;A14;$J$2:$J$9)

Arraste a formula até o final

TIPO DE
VENCIMENTO INTERVALOS DE DIAS "VALOR TOTAL
À VENCER   Acima de 30 29.975,32
range1   0 - 30          4.588,48
range2 31 - 60          4.941,95
range3 61 - 90                -  
range4 91 - 120            948,00
range5 121 - 150                -  
range6 151 - 180                -  
range7 A MAIS 180                -  

Dúvida me manda um e-mail
consultorxls(arrouba)gmail.com
Gilton
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: função somase   Hoje à(s) 5:43 pm

Voltar ao Topo Ir em baixo
 
função somase
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Expressões matemáticas, funções e operadores
» [Resolvido]como usar a função jump to start por codigo?
» [RESOLVIDO]2 funções utilizando a mesma tecla???
» [Vídeo-Aula]Aula 4.1 - Usando funções básicas do draw
» Background - Funções e Variáveis

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: