Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Countar blocos

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
hatchim



Mensagens : 2
Data de inscrição : 01/09/2014

MensagemAssunto: Countar blocos   Seg Set 01, 2014 6:02 pm

Boa tarde

Estou com um problema que não consigo resolver, que é o seguinte:
Tenho uma coluna com valores de 0 e 1 e queria contar os blocos de 15 ums consecutivos, como posso fazer isto??

Obrigado
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Countar blocos   Seg Set 01, 2014 9:25 pm

Boa tarde!!

Código:
=ÍNDICE(FREQÜÊNCIA(FREQÜÊNCIA(SE(A1:A2000=1;LIN(A1:A2000));SE(A1:A2000<>1;LIN(A1:A2000)));{2;15});2)
Essa é uma função matricial, finalize com CTRL+SHIFT+ENTER
Voltar ao Topo Ir em baixo
Ver perfil do usuário
hatchim



Mensagens : 2
Data de inscrição : 01/09/2014

MensagemAssunto: Re: Countar blocos   Ter Set 02, 2014 11:09 am

Muito Obrigado pela ajuda.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Countar blocos   Ter Set 02, 2014 4:02 pm

Bom dia!!

Eu fico feliz em ajudar!!

Obrigado pelo retorno! Laughing

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Countar blocos   Hoje à(s) 10:51 pm

Voltar ao Topo Ir em baixo
 
Countar blocos
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Desvie dos blocos 1
» Sabe aqueles blocos que vem cogumelo??
» B - Blocos sorteados
» [Pedido] Engine de empurrar blocos.
» Mudar cor do título dos blocos do portal

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Intermediário :: Excel Intermediário-
Ir para: