Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Converter dia juliana para data comum no excel

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
geoclaudio



Mensagens : 1
Data de inscrição : 05/12/2010

MensagemAssunto: Converter dia juliana para data comum no excel   Dom Dez 05, 2010 7:18 pm

Olá! No site http://office.microsoft.com/pt-br/excel-help/inserir-datas-do-calendario-juliano-HP003056114.aspx
é mostrado como se converte no Excell uma data comum no formato dia/mês/ano para dia no formato juliano.

A expressão "data do calendário juliano" é às vezes usada para se referir a um formato de data que consiste em uma combinação do ano atual com o número de dias desde o início do ano. Por exemplo, 1º de janeiro de 2007 é representado como 2007001.

Observe que esse formato não é baseado no calendário juliano astronômico.

Por exemplo, o dia 23/06/2007 (célula A2) resultará no dia juliano 2007174, através da seguinte fórmula:

=TEXTO(A2;"aaaa")&TEXTO((A2-DATA.VALOR("1/1/"&TEXTO(A2;"aa"))+1);"000")

A data acima está no formato "juliano", com um ano de quatro dígitos (2007174)
Na fórmula acima, o ano começa em 1º de janeiro (1/1).

O que eu estava procurando era fazer o contrário, ou seja, converter o dia atual no formato "juliano" com ano de quatro dígitos (variável) para a data no formato dia/mês/ano.
Por exemplo, como converter o dia "juliano" 2007174 para o dia 23/06/2007?
Qual a fórmula que devo usar no Excell?

Poderia enviar a resposta para o e-mail
geoclaudio@yahoo.com.br

Grato pela atenção.
Cláudio wILSON mENDES jÚNIOR
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Converter dia juliana para data comum no excel   Qui Jul 14, 2011 1:02 am

Boa noite!!

Veja se é isso

=DATA(ESQUERDA(A1;4)-1;12;31)+DIREITA(A1;3)

Att..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Converter dia juliana para data comum no excel
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Converter esse css para punbb
» Converter access 2003 para access 2007 ou access 2010
» Como colocar barra de separar respostas
» Comando Shell para abrir um arquivo excel ou outro comando?
» Consulta parâmetro com critério para data calculada

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: