Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Procv entre duas tabelas

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Procv entre duas tabelas   Sex Out 03, 2014 5:05 pm

Bom dia,

Preciso fazer uma formula procv utilizando duas matrizes,

A B E F
Projeto Prefixo Projeto Prefixo
1 814 4 815
2 817 5 819


2 =SE(PROCV(A8;A3:B5;2;0);PROCV(A8;A3:B5;2;0);PROCV(A8;A3:B5;2;0))

=SE(PROCV(A8;A3:B5;2;0);PROCV(A8;A3:B5;2;0);PROCV(A8;A3:B5;2;0);PROCV(A8;E3:F5;2;0)
Tentei esta formula porem não deu muito certo...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Sex Out 03, 2014 5:24 pm

Bom dia!!

confused confused

Tente explicar melhor!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Sex Out 03, 2014 5:47 pm

Segue o link de um exemplo básico que eu fiz:

http://www.4shared.com/file/fVYdz-AAce/Procv.html
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Sex Out 03, 2014 8:43 pm

Boa tarde!!

Eu só poderei ver o arquivo quando chegar em casa!

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Sex Out 03, 2014 9:56 pm

sem problemas...grato pela atenção..
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Sab Out 04, 2014 1:48 am

Boa noite!!

Veja se é isso

https://www.sendspace.com/file/lc77f8

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Sab Out 04, 2014 4:57 am

Show, seria isso mesmo...tentei incluir mais uma tabela na mesma procv e não consegui, da erro. Só por curiosidade, como ficaria a inclusão de mais um ou duas provc, qual seria a logica...
Desde já agradeço sua atenção.
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Sab Out 04, 2014 2:17 pm

Bom dia!!

Pode ser assim..?
Código:
=PROC(9;99999999999999E+307;ESCOLHER({1;2;3;4;5};0;PROCV(A8;H3:I5;2;0);PROCV(A8;E3:F5;2;0);PROCV(A8;A3:B5;2;0);PROCV(A8;K3:L5;2;0)))

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Dom Out 05, 2014 1:17 pm

Bom dia,
Não sei o que fiz de errado, mas não funcionou No ....adicionei sua formula e gerado um erro "A formula digitada contem um Erro"...

=PROC(9;99999999999999E+307;ESCOLHER({1;2;3;4;5};0;PROCV(A8;H3:I5;2;0);PROCV(A8;E3:F5;2;0);PROCV(A8;A3:B5;2;0);PROCV(A8;K3:L5;2;0)))

desde já agradeço sua atenção...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Dom Out 05, 2014 2:59 pm

Bom dia!!

Eu não tive problemas.
h t t p s://www.sendspace.com/file/7ro4v0


Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Seg Out 06, 2014 4:01 am

Show...agora funcionou... porem não entendi a logica desta formula, entretanto funciona perfeitamente.
Qual seria a logica desta formula?
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Seg Out 06, 2014 11:15 pm

Boa tarde!

O pai da PROCV e PROCH, procura

http://office.microsoft.com/pt-br/excel-help/funcao-proc-HP010069832.aspx
http://bloginformaticamicrocamp.com.br/2013/10/23/aprenda-a-usar-a-funcao-proc-no-excel/
Código:
=PROC(9;99999999999999E+307
grande valor (em toda dimensão da matriz).

Código:
ESCOLHER({1;2;3;4;5}
escolha uma das matrizes (tabelas com dados)

Código:
PROCV(A8;H3:I5;2;0);PROCV(A8;E3:F5;2;0)
...retorna os resultados do PROCV

Att
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Anacleto



Mensagens : 86
Data de inscrição : 04/04/2012

MensagemAssunto: Re: Procv entre duas tabelas   Qua Out 08, 2014 6:53 pm

Boa Tarde,

Muito bom! Obrigado....
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Procv entre duas tabelas   Qui Out 09, 2014 10:35 pm

Boa tarde!!

Eu fico feliz por ter ajudado.

Att cheers
Voltar ao Topo Ir em baixo
Ver perfil do usuário
Conteúdo patrocinado




MensagemAssunto: Re: Procv entre duas tabelas   Hoje à(s) 10:56 am

Voltar ao Topo Ir em baixo
 
Procv entre duas tabelas
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Consulta utilizando duas tabelas e calculo
» Testar se valores de duas tabelas sao iguais
» Consulta em duas tabelas diferentes
» [Resolvido]Consulta entre duas datas mas com 5 datas como critérios
» Duas praias portuguesas entre as melhores do mundo

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Avançado/VBA :: Excel Avançado/VBA-
Ir para: