Fórum Excel Bácico, Avançado e Vba

Este fórum é destina a usuário de Excel, que queiram compartilhar informações a básicas, avançadas e programação em VBA...
 
InícioInício  FAQFAQ  BuscarBuscar  MembrosMembros  GruposGrupos  Registrar-seRegistrar-se  Login  

Compartilhe | 
 

 Urgente escolher 1 numero de uma lista de numeros sem os repetir

Ver o tópico anterior Ver o tópico seguinte Ir em baixo 
AutorMensagem
pepegym



Mensagens : 1
Data de inscrição : 21/11/2014

MensagemAssunto: Urgente escolher 1 numero de uma lista de numeros sem os repetir   Sex Nov 21, 2014 7:12 pm

Boas,
Precisava de escolher 1 numero de uma lista de 21 números ... de forma que escolhe se automaticamente e aleatoriamente 5 números, sem os repetir, da lista de numeros que tenho .... por exemplo: 1 4 5 11 13 18 19 20 21 23 24 25 27 33 35 37 38 42 44 47 50 ...
Voltar ao Topo Ir em baixo
Ver perfil do usuário
alexandrevba



Mensagens : 1820
Data de inscrição : 13/07/2011
Localização : Serra - ES

MensagemAssunto: Re: Urgente escolher 1 numero de uma lista de numeros sem os repetir   Ter Nov 25, 2014 5:46 pm

Boa tarde!!
Fonte:http://www.tushar-mehta.com/excel/newsgroups/rand_selection/
Na coluna A, insira os numeros desejados.

Na colulna B, insira a formula =ALEATÓRIO(), depois arraste para baixo.

Na coluna C, insira a formula =ÍNDICE($A$2:$A$22;ORDEM(C2;$C$2:$C$22)), depois arraste até ter 5 valores da sua lista.
Código:
Numb   -   =ALEATÓRIO()   -   Resultado
1   -   0,275554163   -   27
4   -   0,742656825   -   5
5   -   0,220285924   -   33
11   -   0,066232317   -   47
13   -   0,191649728   -   38
18   -   0,832604957   -   
19   -   0,932987253   -   
20   -   0,561844159   -   
21   -   0,277188799   -   
23   -   0,007194965   -   
24   -   0,351217287   -   
25   -   0,504206505   -   
27   -   0,4597298   -   
33   -   0,161541825   -   
35   -   0,200867013   -   
37   -   0,423500296   -   
38   -   0,644488773   -   
42   -   0,542461716   -   
44   -   0,092716607   -   
47   -   0,340508438   -   
50   -   0,19723017   -   
Voltar ao Topo Ir em baixo
Ver perfil do usuário
 
Urgente escolher 1 numero de uma lista de numeros sem os repetir
Ver o tópico anterior Ver o tópico seguinte Voltar ao Topo 
Página 1 de 1
 Tópicos similares
-
» Lista com números quando passar o mouse ficar laranja
» The Nuclear Toy (fassa suas bombas e brinque com os elementos) (Nova versão)
» Dividir pelos numeros primos e se nao der aumentar
» Escolher arquivo e copia-lo para outro lugar
» Como colocar numero na baliza código

Permissão deste fórum:Você não pode responder aos tópicos neste fórum
Fórum Excel Bácico, Avançado e Vba :: Usuários Básico :: Excel Básico-
Ir para: